Google Gemini-Verbindung in Jitterbit Studio
Einführung
Eine Google Gemini-Verbindung, die mit dem Google Gemini-Connector erstellt wird, stellt den Zugriff auf Google Gemini her. Nach der Konfiguration einer Verbindung können Sie Instanzen von Google Gemini-Aktivitäten erstellen, die dieser Verbindung zugeordnet sind und entweder als Quellen (um Daten in einem Vorgang bereitzustellen) oder als Ziele (um Daten in einem Vorgang zu verarbeiten) verwendet werden.
Google Gemini-Verbindung erstellen oder bearbeiten
Eine neue Google Gemini-Verbindung wird mit dem Google Gemini-Connector von einem dieser Orte aus erstellt:
- Die Registerkarte Project endpoints and connectors (Projektendpunkte und Connectoren) der Design-Komponentenpalette (siehe Design component palette).
- Die Seite Global Endpoints (Globale Endpunkte) (siehe Create a global endpoint in Global Endpoints).
Eine vorhandene Google Gemini-Verbindung kann von diesen Orten aus bearbeitet werden:
- Die Registerkarte Project endpoints and connectors (Projektendpunkte und Connectoren) der Design-Komponentenpalette (siehe Design component palette).
- Die Registerkarte Components (Komponenten) des Projektbereichs (siehe Component actions menu in Project pane Components tab).
- Die Seite Global Endpoints (Globale Endpunkte) (siehe Edit a global endpoint in Global Endpoints).
Google Gemini-Verbindung konfigurieren
Im Folgenden wird jedes Benutzeroberflächenelement des Konfigurationsbildschirms der Google Gemini-Verbindung beschrieben.
Tipp
Felder mit einem Variablensymbol unterstützen die Verwendung von global variables, project variables und Jitterbit variables. Beginnen Sie entweder mit der Eingabe einer öffnenden eckigen Klammer [ in das Feld oder klicken Sie auf das Variablensymbol, um eine Liste der vorhandenen Variablen anzuzeigen, aus der Sie auswählen können.
-
Connection name: Geben Sie einen Namen ein, um die Verbindung zu identifizieren. Der Name muss für jede Google Gemini-Verbindung eindeutig sein und darf keine Schrägstriche
/oder Doppelpunkte:enthalten. Dieser Name wird auch verwendet, um den Google Gemini-Endpunkt zu identifizieren, der sich auf eine bestimmte Verbindung und ihre Aktivitäten bezieht. -
Platform: Wählen Sie die Google Gemini-Plattform aus, mit der Sie sich verbinden möchten, entweder AI Studio oder Vertex AI.
-
AI Studio: Wählen Sie diese Option, um sich mit Google AI Studio zu verbinden. Wenn diese Option ausgewählt ist, ist dieses Feld sichtbar:
- API key: Geben Sie Ihren Gemini API key ein.
-
Vertex AI: Wählen Sie diese Option, um sich mit der Gemini Enterprise Agent Platform (zuvor als Vertex AI bekannt) zu verbinden. Wenn diese Option ausgewählt ist, sind diese Felder sichtbar:
-
Project ID: Geben Sie die
project_idein, die von der JSON-Datei der service account credentials bereitgestellt wird. -
Location: Geben Sie die Google Cloud region ein, in der Ihre Gemini Enterprise Agent Platform-Ressourcen gehostet werden (z. B.
us-central1). -
Client email: Geben Sie die
client_emailein, die von der JSON-Datei der service account credentials bereitgestellt wird. -
Private key string: Geben Sie den
private_keyein, der von der JSON-Datei der service account credentials bereitgestellt wird. Der private Schlüssel sollte in diesem Format eingegeben werden:
-
-
-----BEGIN PRIVATE KEY-----
<private_key>
-----END PRIVATE KEY-----
Hinweis
Alle Zeilenumbruchzeichen (\n) in der private_key-Zeichenkette müssen durch einen Wagenrücklauf im Feld Private key string ersetzt werden. Andernfalls tritt beim Testen der Verbindung ein Fehler auf.
-
Optionale Einstellungen: Klicken Sie, um zusätzliche optionale Einstellungen zu erweitern:
-
Timeout: Geben Sie den Timeout-Wert in Sekunden ein.
-
Proxy-Einstellungen verwenden (nur Private Agent): Bei Verwendung eines Private Agent kann diese Einstellung ausgewählt werden, um Private-Agent-Proxy-Einstellungen zu nutzen.
-
-
Testen: Klicken Sie, um die Verbindung mit der angegebenen Konfiguration zu überprüfen. Beim Testen der Verbindung wird die neueste Version des Connectors von den Agent(en) in der Agent-Gruppe heruntergeladen, die der aktuellen Umgebung zugeordnet ist. Dieser Connector unterstützt das Aussetzen des Downloads der neuesten Connector-Version durch die Organisationsrichtlinie Disable Auto Connector Update.
-
Speichern: Klicken Sie, um die Verbindungskonfiguration zu speichern und zu schließen.
-
Änderungen verwerfen: Nach Änderungen an einer neuen oder vorhandenen Konfiguration klicken Sie, um die Konfiguration ohne Speichern zu schließen. Eine Meldung fordert Sie auf, zu bestätigen, dass Sie die Änderungen verwerfen möchten.
-
Löschen: Nach dem Öffnen einer vorhandenen Verbindungskonfiguration klicken Sie, um die Verbindung dauerhaft aus dem Projekt zu löschen und die Konfiguration zu schließen (siehe Komponentenabhängigkeiten, Löschung und Entfernung). Eine Meldung fordert Sie auf, zu bestätigen, dass Sie die Verbindung löschen möchten.
Nächste Schritte
Nach dem Erstellen einer Google-Gemini-Verbindung platzieren Sie einen Aktivitätstyp auf der Design-Canvas, um Aktivitätsinstanzen zu erstellen, die entweder als Quellen (um Daten in einer Operation bereitzustellen) oder als Ziele (um Daten in einer Operation zu verarbeiten) verwendet werden.
Menüaktionen für eine Verbindung und ihre Aktivitätstypen sind über den Projektbereich und die Design-Komponentenpalette zugänglich. Weitere Informationen finden Sie unter Aktionsmenüs in Connector-Grundlagen.
Diese Aktivitätstypen sind verfügbar:
-
Register Tools: Registriert Funktionen (Tools) beim angegebenen Modell in Google Gemini und ist als Ziel in einer Operation vorgesehen.
-
Prompt: Sendet einen Prompt an das angegebene Modell in Google Gemini und ist als Ziel in einer Operation vorgesehen.