Ein Skript in Jitterbit Design Studio erstellen
Einführung
Skripte in Design Studio werden verwendet, um Daten zu manipulieren oder erweiterte Logik auszuführen (if, while, case-Anweisungen usw.). Skripte werden häufig in Operationen und Transformationen verwendet, um zusätzliche Funktionen über die grundlegenden Funktionen von Operationen und Transformationen hinaus bereitzustellen. Sie können in der Jitterbit Script-Sprache oder, wenn Sie ein Skript als Projektelement erstellen, in JavaScript geschrieben werden.
Es gibt mehrere Stellen in Design Studio, an denen Sie ein Skript erstellen können, je nachdem, was Sie erreichen möchten. Jede dieser Optionen wird nachfolgend zusammengefasst und später auf dieser Seite ausführlicher beschrieben. Die Benutzeroberfläche zum Erstellen von Skripten ist bei allen Typen ähnlich und wird am Ende dieses Dokuments beschrieben.
-
Skript als Projektelement
Dieser Skripttyp kann in eine Operation eingefügt werden, entweder als Schritt innerhalb einer Operation oder in einer Operation, die dem Ausführen des Skripts gewidmet ist. Es kann auch mit der Funktion RunScript() aufgerufen werden. Dieser Skripttyp wird im Baum auf der linken Seite unter dem Abschnitt Skripte angezeigt. -
Skript auf einem Zielfeld in einer Transformation
Dieser Skripttyp kann auf einem Feld in einer Transformation bearbeitet werden, um die angegebene Logik auf Ihre Transformationszuordnung anzuwenden. Der letzte im Skript zurückgegebene Wert wird als Wert für Ihr Zielfeld verwendet. Dieser Skripttyp ist nur auf allen Feldern innerhalb der Transformationszuordnung verfügbar. -
Skript als Bedingung innerhalb einer Transformation
Dieser Skripttyp kann auf einem Ordner in einer Transformation erstellt werden, um zu bestimmen, ob die Quellinstanz basierend auf dem Ergebnis der Bedingung verwendet wird. Der letzte im Skript zurückgegebene Wert sollte „true" oder „false" sein. Dieser Skripttyp kann nur innerhalb der Transformationszuordnung hinzugefügt werden.Hinweis
Die Verwendung eines Skripts als Bedingung innerhalb einer Transformation sollte nicht mit der Verwendung einer Bedingung für eine Operation verwechselt werden. Letzteres wird separat unter Eine Bedingung erstellen behandelt.
-
Skripttests mit dem Skript-Pad
Das Skript-Pad ist ein Tool in Design Studio, das zum Ausführen grundlegender Tests von Skripten verwendet werden kann, die Sie nicht speichern müssen. Auf dieses Tool können Sie über die Menüleiste unter Ansicht > Skript-Pad zugreifen.
Skripttypen
Skript als Projektelement
Skripte können unabhängig von Transformationen als eigenständiger Operationsschritt ausgeführt werden. Sie können beispielsweise ein Skript erstellen, das eine Datenbanktabelle trunciert, bevor Sie eine Transformation ausführen, um sie erneut zu füllen. Sie können auch Skripte mit Logik speichern, um sie in mehreren Zuordnungen in Transformationen wiederzuverwenden. Sie können Skripte aus anderen Skripten mit der Funktion RunScript() ausführen oder indem Sie sie in eine Operation einfügen.
Innerhalb Ihres Projekts in Design Studio gibt es mehrere Möglichkeiten, ein neues Skript als Projektelement zu erstellen:
- Klicken Sie im Baum auf der linken Seite mit der rechten Maustaste auf den Abschnitt Skripte und wählen Sie Neues Skript oder Neues JavaScript.
-
Klicken Sie in einer vorhandenen Operation mit der rechten Maustaste auf einen beliebigen Einfügungspunkt
und wählen Sie Einfügen > Skript. Oder klicken Sie mit der rechten Maustaste auf eine Quelle oder ein Ziel und wählen Sie Davor einfügen > Skript oder Danach einfügen > Skript. Ein Skriptsymbol wird im Operationsgraph angezeigt. Führen Sie dann einen der folgenden Schritte aus:- Klicken Sie mit der rechten Maustaste auf das Skriptsymbol und wählen Sie Vorhandenes Skript auswählen, Neues Jitterbit-Skript erstellen oder Neues JavaScript erstellen.
- Doppelklicken Sie auf das Skriptsymbol und wählen Sie ein vorhandenes Skript aus der Liste aus, oder verwenden Sie die Schaltflächen zum Erstellen eines neuen Jitterbit-Skripts oder Erstellen eines neuen JavaScripts.
Die Optionen, die sich auf „Jitterbit Script" oder einfach „Script" beziehen, zeigen einen Skript-Builder in der Jitterbit Script-Sprache an.

Ab Version 8.24.2 öffnen Optionen, die sich auf „Javascript" beziehen, einen Script-Builder in JavaScript.

Die Benutzeroberfläche des Script-Builders für beide Typen wird unter Scripts erstellen am Ende dieser Seite behandelt.
Man kann jederzeit über den Baum auf der linken Seite unter Scripts zum vorhandenen Script zurückkehren.
Script in einem Zielfeld in einer Transformation
Dieser Script-Typ kann in einem Feld einer Transformation bearbeitet werden, um die angegebene Logik auf die Transformationszuordnung anzuwenden. Der letzte im Script zurückgegebene Wert wird als Wert für das Zielfeld verwendet. Man kann beispielsweise Scripting verwenden, um ein Feld von String in Int zu ändern, Werte zu verketten, eine Datenbankabfrage für ein Feld durchzuführen oder die bedingte Befüllung des Feldes festzulegen.
Dieser Script-Typ ist nur in allen Feldern innerhalb der Transformationszuordnung verfügbar. Doppelklicken Sie in der Transformationszuordnung auf das Zielfeld, für das Sie das Script bearbeiten möchten.

Dies öffnet den Standard-Script-Builder auf der linken Seite und den Quellenbaum auf der rechten Seite. Scripts in Transformationen müssen die Jitterbit Script-Sprache verwenden. Die Benutzeroberfläche des Script-Builders wird unter Scripts erstellen am Ende dieser Seite behandelt.

Script als Bedingung innerhalb einer Transformation
Dieser Script-Typ kann in einem Ordner einer Transformation erstellt werden, um zu bestimmen, ob die Quellinstanz basierend auf dem Ergebnis der Bedingung verwendet wird. Der letzte im Script zurückgegebene Wert sollte „true" oder „false" sein. Wenn der zurückgegebene Wert kein „true"- oder „false"-Wert ist, wird er als „false" behandelt.
Hinweis
Die Verwendung eines Scripts als Bedingung innerhalb einer Transformation sollte nicht mit der Verwendung einer Bedingung für einen Vorgang verwechselt werden. Letzteres wird separat unter Bedingung erstellen behandelt.
Dieser Script-Typ ist nur innerhalb der Transformationszuordnung zugänglich. Klicken Sie in der Transformationszuordnung mit der rechten Maustaste auf einen Ordner mit „One or More Elements" [E+] oder „Zero or More Elements" [E*] (siehe Erklärung der hierarchischen Entity-Path-Notation) und wählen Sie Bedingung hinzufügen.

Dies erstellt eine Bedingung, die nun unter dem Ordner angezeigt wird. Doppelklicken Sie darauf, um den Standard-Script-Builder auf der linken Seite und den Quellenbaum auf der rechten Seite zu öffnen.

Scripts in Transformationen müssen die Jitterbit Script-Sprache verwenden. Die Benutzeroberfläche des Script-Builders wird unter Scripts erstellen am Ende dieser Seite behandelt.

Script-Tests mit Script Pad
Das Script Pad ist ein Tool in Design Studio, mit dem man grundlegende Tests von Scripts durchführen kann, die nicht gespeichert werden müssen. Dieses Tool ist über die Menüleiste unter View > Script Pad zugänglich.

Dies zeigt ein einfaches Script Pad zu Testzwecken an. Scripts im Script Pad müssen die Jitterbit Script-Sprache verwenden. Die Benutzeroberfläche des Script-Builders wird unter Scripts erstellen am Ende dieser Seite behandelt.

Skripte erstellen
Die Benutzeroberfläche des Skript-Builders funktioniert ähnlich für alle Skripttypen, die weiter oben auf dieser Seite beschrieben werden. Im Folgenden werden alle möglichen Elemente der Skript-Builder-Oberfläche erläutert und es wird erklärt, welche Elemente in den angegebenen Skripttypen verwendet werden können.
Hinweis
Siehe auch Formula Builder-Funktionen für eine Sammlung von Tipps zur Interaktion mit der Benutzeroberfläche.
Skript
Der Skriptbereich, in den man sein Skript eingeben kann, ist in allen Skripttypen vorhanden. Jedes Element des Skripts wird nachfolgend erläutert.

- Zeilennummern: Zeilennummern werden auf der linken Seite des Skripts angezeigt. Um Zeilennummern ein- oder auszuschalten, klicken Sie mit der rechten Maustaste auf den Skripthintergrund und wählen Sie Zeilennummern anzeigen.
-
Skriptbereich: Der Skriptbereich ist der Ort, an dem man sein Skript erstellt. Was man hier eingibt, hängt von der verwendeten Skriptsprache ab.
- Jitterbit Script Language: Bei Skripten, die Jitterbit's Skriptsprache verwenden, muss der endgültige Ausdruck in
<trans>...</trans>Tags enthalten sein. Weitere Informationen zu Syntaxanforderungen und Tipps finden Sie unter Jitterbit Script Language. - JavaScript: Bei Skripten, die JavaScript verwenden, sind keine Tags erforderlich. Geben Sie Ihr Skript einfach hier in JavaScript ein. Weitere Informationen zur Verwendung von JavaScript in Harmony finden Sie unter JavaScript.
Die Verwendung von JavaScript ist derzeit auf Skripte beschränkt, die als Projektelemente erstellt werden. Bei Skripten, die als Projektelemente erstellt werden, wird der Skripttyp auch über dem Skriptbereich neben dem Namen des Skripts aufgelistet:


- Jitterbit Script Language: Bei Skripten, die Jitterbit's Skriptsprache verwenden, muss der endgültige Ausdruck in
-
Validierung: Design Studio bietet grundlegende Syntaxprüfung und Hervorhebung. Wenn das Skript die grundlegende Syntaxvalidierung besteht, wird eine Zeile unter dem Skriptbereich angezeigt: „Skript ist gültig." Wenn das Skript die grundlegende Syntaxvalidierung nicht besteht, werden hier spezifische Fehlerinformationen bereitgestellt.
- Modus: Verwenden Sie dieses Dropdown-Menü, um zwischen dem Modus Entwickler und Business Analyst zu wechseln. Der Entwicklermodus bietet eine Benutzeroberfläche für fortgeschrittene Benutzer, während der Business Analyst-Modus eine benutzerfreundlichere Assistenten-Oberfläche für Nicht-Entwickler bietet.
- Zeile und Spalte: Die Zahlen unten rechts im Skriptbereich geben die Zeile und Spalte im Skript an, an der sich der Cursor befindet. Um zu einer bestimmten Zeile zu springen, klicken Sie mit der rechten Maustaste auf den Skripthintergrund und wählen Sie Gehe zu Zeile.
Quelle
Der Quellenbaum wird im rechten Bereich nur für Skripte angezeigt, die während der Transformationszuordnung erstellt werden, und ist nicht auf Skripte anwendbar, die als Projektelemente erstellt werden. Innerhalb des Skripts können Quelldatenelemente verwendet werden, um auf Quelldaten nach dem Pfad des Feldes im Quellenbaum zu verweisen.

Quelldatenelemente können auf folgende Weise zum Skript hinzugefügt werden:
- Doppelklicken Sie auf das Feld oder den Ordner im Quellenbaum auf der rechten Seite, um es zum Skript auf der linken Seite hinzuzufügen.
- Klicken Sie auf das Feld oder den Ordner im Quellenbaum auf der rechten Seite und verwenden Sie dann das Symbol
, um es zum Skript auf der linken Seite hinzuzufügen. - Geben Sie den Quellpfad direkt in den Skriptbereich ein.
Die folgende Funktionalität ist ebenfalls verfügbar:
- Erweitern/Reduzieren: Verwenden Sie die Symbole
, um alle Elemente im Quellenbaum zu reduzieren oder zu erweitern. - Suche: Wenn Sie viele Elemente in Ihrem Quellenbaum haben, verwenden Sie das Suchsymbol
, um in Ihrem Quellenbaum zu suchen. - Quelldaten laden: Laden Sie Quelldaten mit der Schaltfläche
zu Testzwecken in Ihre Transformation.
Funktionen
Die Registerkarte Funktionen bietet eine Liste der Funktionen, die in Ihrem Skript verwendet werden können. Die verfügbaren Funktionen hängen davon ab, ob Ihr Skript die Jitterbit Script-Sprache oder JavaScript verwendet. Die folgende Funktionalität ist für beide Typen verfügbar:
- Filter: Wenn Sie nach einer bestimmten Funktion suchen, verwenden Sie das Suchfeld über der Funktionsliste.
- Einfügen: Um eine Funktion im Skript zu verwenden, doppelklicken Sie auf die Funktion oder klicken Sie mit ausgewählter Funktion auf das Einfügungssymbol
. - Erweitern/Reduzieren: Verwenden Sie die Symbole
, um die Funktionsliste zu reduzieren oder zu erweitern. - Hilfe: Klicken Sie mit ausgewählter Funktion auf das Symbol
, um die Dokumentation zur Funktion direkt in Studio anzuzeigen.
Bei Verwendung der Jitterbit Script-Sprache sind die verfügbaren Funktionen in Ordnern nach Kategorie organisiert.

Jede Jitterbit Script-Funktion ist in jeder Kategorie dokumentiert:
- Cache-Funktionen
- Connector-Funktionen
- Konvertierungsfunktionen
- Kryptografische Funktionen
- Datenbankfunktionen
- Datums- und Zeitfunktionen
- Debugging-Funktionen
- Wörterbuch- und Array-Funktionen
- Diff-Funktionen
- E-Mail-Funktionen
- Umgebungsinformationsfunktionen
- Dateifunktionen
- Allgemeine Funktionen
- Instance-Funktionen
- LDAP-Funktionen
- Protokollierungs- und Fehlerfunktionen
- Logische Funktionen
- Mathematische Funktionen
- Salesforce-Funktionen
- String-Funktionen
- Textvalidierungsfunktionen
- XML-Funktionen
Bei Verwendung von JavaScript sind die verfügbaren Funktionen in Ordnern für Jitterbit, Keywords, Allgemeine Funktionen oder Mathematik unterteilt.

Jitterbit
Diese Kategorie enthält eine Liste von Funktionen, die spezifisch für Jitterbit sind. Dazu gehören eine begrenzte Anzahl von Standard-Jitterbit-Funktionen sowie eine Reihe von JavaScript-Funktionen, die spezifisch für Jitterbit sind.
Derzeit steht eine begrenzte Anzahl der Jitterbit-Script-Funktionen zur Verwendung in JavaScript zur Verfügung. Um eine dieser Jitterbit-Funktionen in JavaScript zu verwenden, stellen Sie der Funktion "Jitterbit." voran. Diese Jitterbit-Funktionen stehen in Jitterbit zur Verwendung in JavaScript zur Verfügung:
-
Jitterbit.ReadFile(string source_id[, string file_name])liest eine Datei aus der angegebenen Quelle, wie in der Formel-Builder-Dokumentation unter Dateifunktionen beschrieben. Der zurückgegebene Wert ist eine Zeichenkette. Beispiel: In JavaScript mit dieser Jitterbit-Funktion eine Datei lesen:var MyData = Jitterbit.ReadFile("<TAG>Sources/myfile</TAG>"); -
Jitterbit.WriteFile(string target_id, type file_contents[, string file_name])schreibt in eine Datei und leert diese automatisch. Es wird kein Wert zurückgegeben. Siehe WriteFile unter Formel-Builder Dateifunktionen. -
Jitterbit.DbExecute(string database_id, string sql_str, ...)führt eine SQL-Anweisung in einer Datenbank aus und gibt die Ergebnisse zurück. Der zurückgegebene Wert ist eine Zeichenkette. Siehe DBExecute unter Formel-Builder Datenbankfunktionen. -
Jitterbit.DbLookup(string database_id, string sql_str)führt eine SQL-Anweisung in einer Datenbank aus und gibt das erste Ergebnis zurück, das den angegebenen Kriterien entspricht. Der zurückgegebene Wert ist eine Zeichenkette. Siehe DBLookup unter Formel-Builder Datenbankfunktionen. -
Jitterbit.GetVar(string name)undJitterbit.SetVar(string name, string value)Warnung
Die Funktionen
Jitterbit.GetVarundJitterbit.SetVarsind dafür ausgelegt, die Verwendung von Variablen zu ermöglichen, die Punkte im Variablennamen enthalten. Die Verwendung von Punkten in einem Variablennamen wird jedoch nicht empfohlen. Da der Wert beim Festlegen der Variablen in eine Zeichenkette konvertiert wird, können diese Funktionen nicht mit komplexen Datentypen wie Arrays, Dictionaries oder JSON-Objekten verwendet werden. Stattdessen wird empfohlen, globale Variablen ohne Punkte zu erstellen und statt Punkte Unterstriche zu verwenden sowie die Standard-Dollar-Syntax$wie unter Globale Variablen beschrieben zu verwenden.Die Funktion
Jitterbit.GetVarruft eine zuvor zugewiesene globale Jitterbit-Variable ab (eine Variable mit dem Präfix "Jitterbit"). Der zurückgegebene Wert ist der entsprechende Datentyp.Die Funktion
Jitterbit.SetVarweist einen Wert einer globalen Jitterbit-Variablen zu (eine Variable mit dem Präfix "Jitterbit"). Der zurückgegebene Wert ist eine Zeichenkette. Dieses Beispiel verwendet eine benutzerdefinierte API, die einen Vorgang ausführt, der ein JavaScript mitJitterbit.GetVarundJitterbit.SetVarenthält:var response="Hello World"; response += "\r\nOperation Name: " + Jitterbit.GetVar("$jitterbit.operation.name"); response += "\r\ntest_var: " + Jitterbit.GetVar("$jitterbit.api.request.parameters.test_var"); Jitterbit.SetVar("$jitterbit.api.response.headers.content_type","text/plain"); Jitterbit.SetVar("$jitterbit.api.response.headers.test_header", "This is a header test"); Jitterbit.SetVar("$jitterbit.api.response",response);
In dieser Kategorie sind mehrere Funktionen enthalten, die für die Verwendung mit JavaScript in Jitterbit angepasst wurden. Diese Funktionen haben nicht das Präfix "Jitterbit.".
-
WriteToOperationLogsendet Ausgaben an das aktuelle Jitterbit-Operationsprotokoll. Wurde für die Verwendung mit JavaScript in Jitterbit entwickelt und funktioniert ähnlich wie die Jitterbit-Funktion, die unter Formel-Builder Protokollierungs- und Fehlerfunktionen beschrieben ist. -
SetScriptOutputundSetScriptResultlegen die Ausgabe für das Skript fest. Diese beiden Funktionen sind Aliase und können je nach Vorliebe verwendet werden. Im Gegensatz zu Jitterbit-Scripts, die automatisch den Wert der letzten Zeile zurückgeben, geben Jitterbit-JavaScripts nicht automatisch einen Wert zurück. Sie können eine dieser Funktionen in Ihrem JavaScript verwenden, um das Skriptergebnis zurückzugeben. Beispiel:var MyVariable = "Hello World"; WriteToOperationLog(MyVariable); SetScriptResult(MyVariable);
Schlüsselwörter
Diese Kategorie enthält eine Liste von JavaScript-Schlüsselwörtern im ECMAScript 5.1-Standard und wird hier zur Vereinfachung bereitgestellt.
Häufig verwendete Funktionen
Diese Kategorie enthält eine Liste von JavaScript-Funktionen im ECMAScript 5.1-Standard, die für Jitterbit-Benutzer relevant sein können. Diese Kategorie ist nicht vollständig – Sie können auch andere JavaScript-Funktionen verwenden, die hier nicht aufgeführt sind, wie z. B. JavaScript Array-, Date- und String-Objekte und ihre zugehörigen Funktionen.
Hinweis
Eine umfassende Liste der JavaScript-Funktionen finden Sie im ECMAScript 5.1-Standard unter https://www.ecma-international.org/ecma-262/5.1/.
Mathematik
Diese Kategorie enthält Funktionseigenschaften, die für das JavaScript math-Objekt gemäß dem ECMAScript 5.1-Standard verfügbar sind. Diese Kategorie wird zur Vereinfachung bereitgestellt. Die umfassende Dokumentation finden Sie im ECMAScript 5.1-Standard.
Projektelemente
Die Registerkarte Projektelemente bietet eine Liste der Projektelemente, die in Ihrem Skript verwendet werden können, organisiert nach Elementtyp. Diese entsprechen den Elementen, die Sie auf der linken Seite von Studio in der Projektstruktur sehen (z. B. eine vorhandene Quelle oder ein Ziel).

Die Filter-, Einfügungs- und Expand/Collapse-Optionen sind dieselben wie unter „Funktionen" oben beschrieben.
Datenelemente
Die Registerkarte Datenelemente bietet verfügbare Globale Variablen, Projektvariablen und Jitterbit-Variablen.

-
Globale Variablen: Globale Variablen werden zur Laufzeit des Vorgangs festgelegt und stehen downstream des Vorgangs zur Verfügung (d. h. in einer Vorgangskette). Weitere Informationen finden Sie unter Globale Variablen.
-
Projektvariablen: Projektvariablen können vor der Laufzeit des Vorgangs vordefiniert werden und stehen global in Ihrem Projekt zur Verfügung (z. B. in Quellen und Zielen, für Anmeldedaten usw.). Projektvariablen werden als Projektobjekte erstellt und erscheinen in der Projektstruktur auf der linken Seite von Design Studio. Sie können auch über die Management Console auf der Seite Projekte unter der Registerkarte Projektvariablen oder über Citizen Integrator bearbeitet werden, falls in einem Citizen Integrator-Rezept enthalten.
Hinweis
Alle Änderungen an Projektvariablen über die Management Console werden sofort wirksam.
-
Jitterbit-Variablen: Jitterbit-Variablen werden von Harmony vordefiniert oder können in der Konfigurationsdatei des privaten Agenten vordefiniert werden (siehe Konfigurationsdatei bearbeiten (jitterbit.conf)). Jitterbit-Variablen werden auch als vordefinierte globale Variablen bezeichnet. Jede Jitterbit-Variable ist dokumentiert:
Auf der Registerkarte Data Elements können Sie auch eine globale Variable in eine Projektvariable umwandeln und sehen, wo jedes Ihrer Datenelemente in Ihrem Projekt verwendet wird. Um auf diese Optionen zuzugreifen, klicken Sie mit der rechten Maustaste auf eine Variable, um die folgenden Optionen anzuzeigen:
-
Promote to a Project Variable: Wenn Sie eine globale Variable haben, die Sie statisch machen möchten, können Sie diese Option verwenden, um sie in eine Projektvariable umzuwandeln. Diese Option ist für aktuelle Projektvariablen und Jitterbit-Variablen ausgegraut.

-
View References: Wenn Sie viele Variablen in Ihrem Projekt haben, können Sie diese Option verwenden, um zu sehen, wo jede verwendet wird. Das Anzeigen von Referenzen zeigt eine Tabelle mit Projektelementen an, einschließlich Informationen zur Zuordnung und zum Zugriff.

Die Filter- und Einfügeoptionen sind die gleichen wie die unter Funktionen beschriebenen.
Hinweis
Lokale Variablen werden in diesem Abschnitt nicht aufgelistet, da sie nicht global verfügbar sind. Sie können sie jedoch weiterhin lokal in Ihrem Skript verwenden. Weitere Informationen finden Sie unter Lokale Variablen.
Plugins
Die Registerkarte Plugins listet die Plugins auf, die in Ihrem Jitterbit Script verwendet werden können. Derzeit wird die Verwendung von Plugins in JavaScript nicht unterstützt. Wenn Sie ein Plugin in einem Skript verwenden möchten, verwenden Sie bitte ein Jitterbit Script.
Hinweis
Nicht alle Plugins können in Skripten verwendet werden; einige gelten nur für Quellen/Ziele. Weitere Informationen finden Sie unter Customizations > Plug-ins.

- Insert: Um auf ein Plugin im Skript zuzugreifen, doppelklicken Sie auf das Plugin oder klicken Sie mit ausgewähltem Plugin auf das Einfügesymbol
. - View Manifest: Klicken Sie mit ausgewähltem Plugin auf das Symbol
, um das Plugin-Manifest anzuzeigen. - Refresh: Wenn Sie gerade ein Plugin hinzugefügt haben, müssen Sie möglicherweise auf das Aktualisierungssymbol
klicken, um die Liste der verfügbaren Plugins zu aktualisieren.
Test
Die Registerkarte Test ermöglicht es Ihnen, einen unabhängigen Testlauf Ihres Skripts durchzuführen, um die resultierenden Werte von Datenelementen zu überprüfen.

-
Run: Die obere Zeile bietet Optionen zum Ausführen oder Beenden Ihres Skripts, einschließlich Start testing, Resume the current testing session, Run the next statement in the current test und Stop the current testing session. Das Symbol
, das den Test startet, hat die gleiche Funktionalität wie die Test-Schaltflächen
, die an anderen Stellen in der Benutzeroberfläche zu sehen sind. -
Disable breakpoints: Verwenden Sie dieses Kontrollkästchen, um Haltepunkte in einem Jitterbit Script auszuschalten. Haltepunkte können zu Debugging-Zwecken verwendet werden, um beispielsweise den Testlauf zu unterbrechen und Variablen anzusehen. Weitere Informationen finden Sie unter Debugging functions.
Hinweis
Diese Option ist in JavaScript nicht anwendbar, da Debugging in JavaScript nicht verfügbar ist.
-
Reset: Klicken Sie auf die Schaltfläche „Reset"
, um sich auf einen neuen Test vorzubereiten, indem Sie die Datenelement-Liste zurücksetzen. -
Data Elements: Globale Datenelemente werden durch ein globales Symbol
gekennzeichnet. Quelldatenelemente (die aus einem Quellenbaum in einer Transformation referenziert werden) werden durch ein Quellsymbol
gekennzeichnet. Verwenden Sie das Kontrollkästchen Is Null, wenn Sie Werte zu Testzwecken deaktivieren möchten. -
Ergebnis: Das Feld auf der rechten Seite zeigt den Status des Testlaufs während des Tests und das Ergebnis nach Abschluss an.