App Builder-Connector in Jitterbit App Builder
Übersicht
Der App Builder-Connector ist eine Funktion, mit der eine Anwendung Tabellen und Business Objects aus einer anderen App Builder-Anwendung oder aus einer ganz anderen App Builder-Umgebung nutzen kann, als wären sie Teil ihrer eigenen Datenquelle, ohne die zugrunde liegenden Daten zu duplizieren.
Welche Variante man verwendet, hängt davon ab, wo sich die andere Anwendung befindet:
-
Ein lokaler Connector verbindet zwei Datenquellen auf demselben App Builder-Server. Wenn beispielsweise der Server sowohl eine
Northwinds-Datenquelle als auch eine separateMy Applicationhostet undMy ApplicationDaten ausNorthwindslesen (und optional schreiben) muss, ermöglicht ein lokaler ConnectorMy Applicationden direkten Zugriff auf die Tabellen vonNorthwinds, ohne diese Daten in die eigene Datenbank vonMy Applicationzu kopieren. Da beide Anwendungen auf demselben Server ausgeführt werden, verarbeitet App Builder die Verbindung intern: Es ist kein Netzwerkaufruf und kein separater Authentifizierungsschritt erforderlich. -
Ein Remote-Connector verbindet zwei völlig separate App Builder-Umgebungen, jede mit ihrer eigenen URL, über HTTP. Beispielsweise die Verbindung des App Builder-Servers der Organisation mit einer anderen App Builder-Installation, egal ob separate Umgebung, Installation eines anderen Kunden oder eine andere unabhängig gehostete Instanz. Da die Verbindung über das Netzwerk zu einer separaten gesicherten App Builder-Instanz führt, erfolgt die Authentifizierung mithilfe eines API-Schlüssels, auf die gleiche Weise wie bei jedem anderen externen REST-Client.
Diese Seite behandelt:
-
Lokaler App Builder-Connector
Konfiguriere einen Connector zwischen zwei Datenquellen in derselben Umgebung. -
Remote-Connector
Konfiguriere einen Connector zwischen zwei separaten App Builder-Umgebungen über HTTP.
Darüber hinaus enthält diese Seite auch einen Bereich Einschränkungen, in dem bekannte Beschränkungen behandelt werden, die vor der Nutzung des App Builder-Connectors zu beachten sind, sowie einen Bereich Troubleshooting mit häufigen Fehlern und deren Behebung.
Warnung
Wir empfehlen, sich vor der eigenständigen Konfiguration eines App Builder-Connectors mit Ihrem dedizierten Jitterbit-Berater abzustimmen.
Lokaler App Builder-Connector
Ein lokaler App Builder-Connector ermöglicht einer Anwendung auf dem App Builder-Server den direkten Zugriff auf Tabellen und Business Objects, die sich in der Datenquelle einer anderen Anwendung auf demselben Server befinden, ohne die Daten zu kopieren oder eine Netzwerkauthentifizierung einzurichten. Wenn beispielsweise My Application Daten lesen muss, die sich in der Northwinds-Datenquelle befinden, beide auf demselben Server gehostet, ermöglicht ein lokaler Connector My Application den direkten Zugriff auf die öffentlichen Tabellen von Northwinds.
Dieser Abschnitt behandelt:
- Schritt 1: Erstelle einen lokalen App Builder-Connector
- Schritt 2: Gewähre öffentlichen Zugriff auf die Tabellen und Business Objects, die du in deinem Connector verwenden möchtest
- Schritt 3: Erstelle eine Datenquelle mit dem lokalen App Builder-Connector
- Schritt 4: Importiere Tabellen und Business Objects in deinen Connector
- Schritt 5: Füge deinen lokalen App Builder-Connector als Datenquelle zu deiner Anwendung hinzu
- Schritt 6: Verknüpfe deine lokale App Builder-Connector-Datenquelle und deine relationale Datenbank
Erwäge stattdessen „Extend Table"
Wenn du nur eine Tabelle aus einer anderen Datenquelle auf demselben Server abrufen musst, ist Extend Table normalerweise die bessere Wahl: Im Gegensatz zu einem lokalen Connector ist es nicht erforderlich, beide Apps bei jeder Veröffentlichung zusammen zu bündeln und zu versenden.
Schritt 1: Erstelle einen lokalen App Builder-Connector
Richte den App Builder-Connector-Server ein, damit App Builder weiß, dass Anfragen für diese Verbindung lokal statt über HTTP weitergeleitet werden sollen:
- Wählen Sie IDE > Data Servers aus.
-
Klicken Sie im Bereich Data Servers auf + Server. Das Dialogfeld Server wird geöffnet. Geben Sie die folgenden Werte ein:

- Name: Geben Sie Ihrer Serververbindung einen Namen. Jitterbit empfiehlt
Local App Builder. - Type: Wählen Sie App Builder Connector aus.
- App Builder Type: Wählen Sie Local aus.
- Name: Geben Sie Ihrer Serververbindung einen Namen. Jitterbit empfiehlt
-
Klicken Sie auf Save und schließen Sie das Dialogfeld.
Schritt 2: Öffentlichen Zugriff auf die Tabellen und Business Objects aktivieren, die Sie in Ihrem Connector verwenden möchten
Eine Tabelle oder Regel muss als Public gekennzeichnet sein, bevor ein Connector sie verwenden kann:
- Navigieren Sie zur App Workbench für die App, die Sie verwenden möchten.
-
Kennzeichnen Sie die Tabellen oder Regeln, die Sie in Ihrem Connector verwenden möchten, als Public:
-
So kennzeichnen Sie eine Tabelle als öffentlich:
- Gehen Sie zur Registerkarte Tables.
- Suchen Sie die Tabelle im Bereich Tables und klicken Sie auf das Symbol zum Bearbeiten oder doppelklicken Sie auf die Zeile. Die Seite Table Definition für diese Tabelle wird geöffnet.
-
Klicken Sie im Bereich Table auf More > Edge Case. Das Dialogfeld Edge Case Settings wird geöffnet:

-
Aktivieren Sie in der Feldgruppe Public Access je nach Bedarf die Optionen Allow Read und/oder Allow Write.
-
So kennzeichnen Sie eine Regel als öffentlich:
- Gehen Sie zur Registerkarte Rules.
- Suchen Sie die Regel im Bereich Rules und klicken Sie auf das Symbol zum Bearbeiten oder doppelklicken Sie auf die Zeile. Der Rule Builder für diese Regel wird geöffnet.
-
Klicken Sie im Bereich Rule auf More > Edge Case. Das Dialogfeld Edge Case Settings wird geöffnet:

-
Aktivieren Sie in der Feldgruppe Allow Public Access die Option Read, um das Lesen der Daten der Regel zu ermöglichen, und/oder Write, um das Ändern zu ermöglichen.
-
Hinweis
Wir empfehlen dringend, eine öffentliche Tabelle oder ein Business Object nicht zu ändern, nachdem sie öffentlich gemacht und in einem Connector verwendet worden sind. Weitere Informationen finden Sie unter Limitations.
Schritt 3: Erstellen Sie eine Datenquelle mit dem lokalen App Builder Connector
Erstellen Sie mit dem Connector-Server und den als öffentlich gekennzeichneten Objekten eine Datenquelle, die auf die spezifische Anwendung verweist, deren Daten Sie verwenden möchten:
- Gehen Sie zu IDE > Data Servers.
- Wählen Sie im Bereich Data Servers die Option Local App Builder aus.
-
Klicken Sie auf + Source. Ein Assistent wird angezeigt, der Sie durch den Prozess führt:

-
Wählen Sie eine Datenbank aus, für die eine Datenquelle erstellt werden soll. Die Datenquelle wird mit dem gleichen Namen wie die Datenbank erstellt. Klicken Sie auf Next.
Hinweis
Die relationale Datenbank, die Sie suchen, muss mindestens eine öffentliche Tabelle oder Regel haben (siehe Schritt 2); andernfalls kann sie nicht ausgewählt werden.
-
Wählen Sie im nächsten Schritt des Assistenten aus, welche Tabellen, Ansichten und gespeicherten Prozeduren in die neu erstellte Quelle importiert werden sollen, oder klicken Sie auf Import All, um alles zu importieren. Klicken Sie auf Next.
- Der Assistent zeigt eine Zusammenfassung der neuen Datenquelle. Klicken Sie auf Done. Die neue Datenquelle wird nun unter + Source aufgelistet.
-
(Empfohlen) Es ist eine Best Practice, die Datenquelle nach der Konvention
[Data Source You're Connecting to] ([Application Using the Connector])umzubenennen. Beispielsweise würde ein lokaler Connector für Northwinds, der sich mit einer Anwendung namensMy Applicationverbindet, den NamenNorthwinds (My Application)erhalten. Gehen Sie wie folgt vor, um Ihre Datenquelle umzubenennen: -
Klicken Sie auf das Symbol „Neues Fenster" auf der Kachel der Datenquelle oder doppelklicken Sie auf die Kachel selbst. Das Dialogfeld App Builder Connector wird geöffnet:
{style="width: 600px"}-
Klicken Sie auf Bearbeiten. Das Dialogfeld Data Storage Layer wird geöffnet:

-
Klicken Sie erneut auf Bearbeiten. Geben Sie einen angemessenen Namen in das Feld Data Source Name ein.
- Klicken Sie auf Speichern.
-
Tipp
Erstellen Sie jedes Mal eine separate Datenquelle, wenn Sie eine Anwendung mit einer anderen relationalen Datenbank verbinden möchten, anstatt eine übergreifend für Anwendungen zu verwenden. Wenn zwei Anwendungen beispielsweise beide eine lokale Verbindung zu Northwinds benötigen, erstellen Sie zwei Datenquellen nach der obigen Namenskonvention: Northwinds (My Application 1) und Northwinds (My Application 2).
Schritt 4: Tabellen und Geschäftsobjekte in den Connector importieren
Falls Sie die oben beschriebenen Schritte der Reihe nach befolgt haben, wurden die öffentlichen Tabellen und Regeln beim Erstellen der Datenquelle importiert. Fahren Sie mit Schritt 5 fort. Falls Sie die Datenquelle jedoch erstellt haben, bevor Sie den öffentlichen Zugriff auf die benötigten Tabellen und Regeln zugelassen haben, können Sie diese jetzt importieren.
- Gehen Sie zu IDE > Data Servers.
- Wählen Sie im Panel Data Servers die Option Local App Builder aus.
-
Klicken Sie im seitlichen Panel auf das Symbol „Neues Fenster" auf der Kachel der Datenquelle oder doppelklicken Sie auf die Kachel selbst. Das Dialogfeld App Builder Connector wird geöffnet:

-
Klicken Sie in Data Storage Layer auf Importieren. Das Dialogfeld Import Schema wird geöffnet:

-
Zum Importieren aller Tabellen, die Sie als öffentlich gekennzeichnet haben, klicken Sie erneut auf Importieren in Import Capabilities.
-
Zum Importieren einer Teilmenge geben Sie zuerst einen Tabellen- oder Geschäftsobjektnamen in das Feld Import Pattern ein und klicken dann auf Importieren in Import Capabilities.
-
-
Klicken Sie auf Fortfahren. App Builder führt einen Hintergrund-Job aus, um den Import abzuschließen.
Schritt 5: Fügen Sie den lokalen App Builder Connector als Datenquelle zu Ihrer Anwendung hinzu
Die in Schritt 3 erstellte Datenquelle existiert auf dem Server, aber Ihre Anwendung kann sie erst nutzen, wenn Sie sie explizit als Quelle hinzufügen:
- Navigieren Sie zur App Workbench für die Anwendung, die Sie ändern möchten.
- Gehen Sie zur Registerkarte Data Sources.
- Klicken Sie im Panel Data Sources auf + Source. Das Dialogfeld Add a Source to your application wird geöffnet.
- Wählen Sie Link to existing source aus und klicken Sie auf Next.
- Suchen Sie die in Schritt 3 erstellte Datenquelle und klicken Sie auf Link 1 Source.
- Überprüfen Sie das vorgeschlagene Update und klicken Sie auf Done.
Schritt 6: Verknüpfen Sie die Datenquelle des lokalen App Builder Connectors mit Ihrer relationalen Datenbank
Durch das Verknüpfen von Quellen können Sie beidseitig Regeln über mehrere Datenquellen hinweg erstellen:
-
So erstellen Sie Regeln mit der relationalen Datenbank als Quelle und Ihrer lokalen App Builder Connector-Datenquelle als Ziel:
- Navigieren Sie zur App Workbench für die Anwendung, die Sie ändern möchten.
- Gehen Sie zur Registerkarte Data Sources.
- Wählen Sie die zu verknüpfende relationale Datenbank aus. Das seitliche Panel wird mit ihren Optionen gefüllt.
- Klicken Sie in der Feldgruppe Business Logic Layer auf Link Sources. Das Dialogfeld Linked Data Sources wird geöffnet.
- Klicken Sie auf Create und wählen Sie die lokale App Builder Connector-Datenquelle aus, die Sie Ihrer Anwendung in Schritt 5 hinzugefügt haben.
- Klicken Sie auf das Häkchen , um den Datensatz zu speichern.
Einmal verknüpft, können Sie Tabellen und Geschäftsobjekte aus der lokalen App Builder-Datenquelle in Geschäftsregeln und XP CRUD-Regeln verwenden, die in der relationalen Datenbank erstellt werden, einschließlich XP CRUD-Regeln, deren Quelldatenquelle die relationale Datenbank und deren Zieldatenquelle Ihr lokaler App Builder ist. Erstellen Sie diese XP CRUD-Regeln in der relationalen Datenbank.
-
Um Regeln in die entgegengesetzte Richtung zu erstellen, mit Ihrem lokalen App Builder-Connector als Quelle und der relationalen Datenbank als Ziel:
- Navigieren Sie zur App Workbench für die App, die Sie ändern möchten.
- Gehen Sie zur Registerkarte Datenquellen.
- Wählen Sie den lokalen App Builder-Connector, den Sie verknüpfen möchten. Das seitliche Fenster wird mit seinen Optionen gefüllt.
- Klicken Sie in der Feldgruppe Business Logic Layer auf Quellen verknüpfen. Das Dialogfeld Verknüpfte Datenquellen wird geöffnet.
- Klicken Sie auf Erstellen und wählen Sie die relationale Datenquelle aus, mit der Sie eine Verbindung herstellen möchten.
- Klicken Sie auf das Häkchen, um den Datensatz zu speichern.
Einmal verknüpft, können Sie Tabellen und Geschäftsobjekte aus der relationalen Datenbank in Geschäftsregeln und XP CRUD-Regeln verwenden, die im lokalen App Builder-Connector erstellt werden, einschließlich XP CRUD-Regeln, deren Quelldatenquelle der lokale App Builder ist und deren Zieldatenquelle Ihre relationale Datenquelle ist. Erstellen Sie diese XP CRUD-Regeln im lokalen App Builder-Connector.
Remote-Connector
Ein Remote-Connector ermöglicht einer Anwendung in einer App Builder-Umgebung, ein gemeinsames Objekt aus einer völlig separaten App Builder-Umgebung zu nutzen, die unter ihrer eigenen URL über HTTP erreichbar ist. Im Gegensatz zu einem lokalen Connector teilen sich die beiden Umgebungen keinen Server, daher müssen sie sich gegenseitig explizit mit einem API-Schlüssel authentifizieren. Die folgenden Schritte geben zuerst ein Objekt in der Quellumgebung frei und verbinden sich dann von der Remote-Umgebung aus damit.
Dieser Abschnitt behandelt:
- Schritt 1: Das freizugebende Objekt mit dem App Builder-Connector erstellen
- Schritt 2: Remote-App Builder-Verbindungen aktivieren
- Schritt 3: Bestätigen, dass ein API-Schlüssel-Sicherheitsanbieter konfiguriert ist
- Schritt 4: Eine Rolle erstellen, um das Objekt freizugeben
- Schritt 5: Eine Gruppe erstellen und ihr Zugriff gewähren
- Schritt 6: Einen Benutzer erstellen, einen API-Schlüssel generieren und ihn der Gruppe hinzufügen
- Schritt 7: Die Verbindung aus der Remote-Umgebung einrichten
Schritt 1: Das freizugebende Objekt mit dem App Builder-Connector erstellen
Bevor eine Remote-Umgebung Daten von dieser abrufen kann, brauchen Sie etwas zum Freigeben. Dieser Schritt erstellt eine Regel, die genau definiert, was verfügbar gemacht wird:
- Navigieren Sie zur App Workbench für die App, die Sie freigeben möchten, und gehen Sie dann zur Registerkarte Regeln.
-
Klicken Sie auf + Regel. Der Rule Builder wird geöffnet:
- Name: Weisen Sie einen Namen für die Regel zu. Beispiel:
Customer (Remote). - Zweck: Wählen Sie Geschäftsobjekt.
- Ziel: Wählen Sie eine Zieltabelle für die Regel. Beispiel:
Customer.
- Name: Weisen Sie einen Namen für die Regel zu. Beispiel:
-
Klicken Sie auf Erstellen.
- Wählen Sie im Fenster Tabellen die Spalten aus, die Sie freigeben möchten.
-
Gehen Sie im Fenster Regel zu Mehr > Edge Case. Das Dialogfeld Edge Case-Einstellungen wird geöffnet:

-
Aktivieren Sie unter Öffentlichen Zugriff erlauben Lesen und/oder Schreiben je nach Bedarf, damit die Remote-Umgebung auf das Objekt zugreifen kann.
- Klicken Sie auf Fortfahren.
Schritt 2: Remote-App Builder-Verbindungen aktivieren
Ein Objekt freizugeben ist nicht ausreichend: Die Anwendung muss auch explizit Remote-Connector-Anfragen akzeptieren dürfen und seit App Builder 4.67 mit den zulässigen Anbietern zu ihrer Authentifizierung verknüpft sein:
- Gehe zu IDE > Zusätzliche Einstellungen.
-
Klicke im Bereich Konfigurieren auf Remote Connector. Das Dialogfeld Datenquellen wird geöffnet:

-
Aktiviere die Zulassen-Spalte für die Anwendung, für die du Remote-Verbindungen zulassen möchtest.
- Klicke auf Weiter oder das Häkchen .
-
(Seit App Builder 4.67.) Klicke auf die Schaltfläche Authentifizierung konfigurieren für die Anwendung. Das Dialogfeld Authentifizierungsanbieter wird geöffnet. Füge die API-Schlüssel-, HTTP- oder Authorization-Server-Anbieter hinzu, die du für die Authentifizierung seiner Remote-Connector-Anforderungen zulassen möchtest. Unter Endpoint konfigurieren findest du die genauen Schritte.
Hinweis
Diese Option ist bei einer versiegelten Anwendung nicht verfügbar. Klicke bei einer versiegelten Anwendung stattdessen auf das Symbol in ihrer Web-Service-Spalte unter Anwendungen, das dieses gleiche Dialogfeld Authentifizierungsanbieter von außerhalb der App öffnet.
Schritt 3: Bestätige, dass ein API-Schlüssel-Sicherheitsanbieter konfiguriert ist
Die Remote-Umgebung authentifiziert sich bei dieser mithilfe eines API-Schlüssels. Stelle daher sicher, dass dieser Sicherheitsanbieter existiert und aktiviert ist, bevor du einen generierst:
- Gehe zu IDE > Sicherheitsanbieter.
- Bestätige, dass ein aktivierter API-Schlüssel-Sicherheitsanbieter konfiguriert ist. Falls nicht, konfiguriere einen (siehe Sicherheitsanbieter – API-Schlüssel, um zu erfahren, wie das geht).
Schritt 4: Erstelle eine Rolle zum Freigeben des Objekts
Die Schritte 4 bis 6 stellen eine empfohlene Best Practice dar, keine Voraussetzung: Sie beschränken den Zugriff der Remote-Umgebung auf nur das Objekt, das du freigibst, indem du eine dedizierte Rolle, Gruppe und einen Benutzer erstellst und anschließend den API-Schlüssel für diesen Benutzer generierst. Wenn du diese Schritte überspringst und stattdessen einen API-Schlüssel für einen vorhandenen Benutzer generierst, und die Datenquelle dieses Benutzers keine konfigurierten Rollen hat, gewährt der Schlüssel Zugriff auf jedes Objekt, das du in Schritt 1 als Lesen zulassen und/oder Schreiben zulassen markiert hast, nicht nur auf das, das du hier freigibst.
- Navigiere zur App Workbench für die App und gehe dann zur Registerkarte Rollen. Wenn die App mehr als eine Datenquelle hat, wähle die aus, zu der das freigegebene Objekt gehört, über das Datenquellen-Menü oben auf der Seite.
-
Klicke auf + Rolle (siehe unten):
-
Das Dialogfeld Rolle wird geöffnet. Weise einen Namen für die Rolle zu. Beispiel:
Remote Connector. -
Klicke auf Speichern. Der Bereich Berechtigungen wird interaktiv verfügbar:

-
Klicke auf + Berechtigung, wähle das Objekt aus, das du in Schritt 1 erstellt hast, und aktiviere dann nach Bedarf Lesen, Einfügen, Aktualisieren und/oder Löschen.
- Klicke auf das Häkchen , um zu speichern.
Hinweis
Weitere Informationen zu Rollen findest du unter Rollen.
Schritt 5: Erstelle eine Gruppe und gewähre ihr Zugriff
Erstelle eine dedizierte Gruppe, als die sich die Remote-Umgebung authentifizieren kann:
-
Navigiere zu IDE > Benutzerverwaltung und wähle die Registerkarte Gruppen:
-
Klicke auf + Gruppe. Das Dialogfeld Gruppe wird geöffnet:

-
Weise einen Namen zu. Beispiel:
Remote Connector. - Klicke auf Speichern.
- Klicke auf Berechtigungen verwalten. Die Bereiche Berechtigungen und Rollen werden geöffnet.
- Klicke im Bereich Berechtigungen auf Erstellen. Das Dialogfeld Berechtigung wird geöffnet:

- Type: Wählen Sie Application aus.
-
Application: Wählen Sie die Anwendung aus, die das Objekt enthält, das Sie freigeben. Beispiel:
Global Imports. -
Klicken Sie auf Save.
- Suchen Sie im Bereich Roles die Rolle, die Sie in Schritt 4 erstellt haben, und klicken Sie auf Grant.
Hinweis
Die Remote-Umgebung benötigt auch die integrierte Rolle App Builder Remote Connector, auf die unter 403 forbidden error verwiesen wird. Falls diese noch nicht gewährt wurde, suchen Sie sie im selben Bereich Roles und klicken Sie ebenfalls auf Grant.
Schritt 6: Einen Benutzer erstellen, einen API-Schlüssel generieren und ihn der Gruppe hinzufügen
Erstellen Sie einen dedizierten Benutzer für die Remote-Umgebung zur Authentifizierung und generieren Sie die Anmeldedaten für die Verbindung:
-
Wählen Sie die Registerkarte Users aus:
-
Klicken Sie auf + User. Das Dialogfeld User wird angezeigt:

-
Weisen Sie einen User Name zu. Beispiel:
RemoteConnector. - Klicken Sie auf Save.
- Klicken Sie auf More > Keys.
-
Klicken Sie auf Create. Das Dialogfeld Generate Key wird angezeigt:

-
Wählen Sie API Key als Provider aus und klicken Sie auf Save.
-
Kopieren Sie den generierten Key-Wert in Ihre Zwischenablage.
Warnung
Der generierte Schlüsselwert kann nicht mehr abgerufen werden, sobald Sie den Bildschirm Generate Key verlassen. Falls Sie ihn verlieren, müssen Sie einen neuen generieren.
-
Klicken Sie auf + Membership, wählen Sie die Gruppe aus, die Sie in Schritt 5 erstellt haben, und klicken Sie auf das -Häkchen zum Speichern.
Schritt 7: Die Verbindung aus der Remote-Umgebung einrichten
Alle bisherigen Schritte fanden in der Umgebung statt, die das Objekt freigegeben hat. Dieser letzte Schritt wechselt zur Remote-Umgebung und verwendet die gerade erstellten Anmeldedaten, um die Verbindung herzustellen:
- Navigieren Sie zur Remote-Umgebung, von der aus Sie die Verbindung herstellen möchten, gehen Sie dann zu App Workbench für die Anwendung, mit der Sie eine Verbindung herstellen möchten, und wählen Sie die Registerkarte Data Sources aus.
- Klicken Sie auf + Source. Ein Assistent wird angezeigt, um Sie zu unterstützen.
- Wählen Sie im ersten Bildschirm des Assistenten New Connection aus und klicken Sie auf Next.
-
Wählen Sie Other als Connection Category aus, suchen Sie dann nach App Builder Connector und wählen Sie es aus:

-
Klicken Sie auf Next. Der Assistent überspringt den Schritt Choose Provider für diesen Verbindungstyp und geht direkt zu Create Connection über.
-
Geben Sie die folgenden Werte ein:

- Server Name: Weisen Sie einen Namen zu. Beispiel:
Remote. - App Builder Type: Bestätigen Sie, dass dies auf Remote eingestellt ist.
- Url: Geben Sie die URL der Umgebung ein, mit der Sie eine Verbindung herstellen. Beispiel:
https://example.com. - Api Key: Fügen Sie den Schlüsselwert ein, den Sie in Schritt 6 kopiert haben.
- Server Name: Weisen Sie einen Namen zu. Beispiel:
-
Klicken Sie auf Next und führen Sie dann die verbleibenden Schritte des Assistenten aus (Choose Database, Import Schema und Summary), um die Datenbank auszuwählen, die Tabellen, Ansichten und gespeicherten Prozeduren zu importieren, mit denen Sie eine Verbindung herstellen möchten, und bestätigen Sie die neue Verbindung.
- Wählen Sie die Remote-App-Builder-Connector-Datenquelle aus und klicken Sie auf Logic.
- Klicken Sie auf das Symbol Results für einen Eintrag, um zu bestätigen, dass Daten angezeigt werden.
- Testen Sie die Verbindung: Bearbeiten Sie einen Datensatz und speichern Sie ihn. Kehren Sie dann zur anderen Umgebung zurück und bestätigen Sie, dass die Aktualisierung dort ebenfalls angezeigt wird.
Limitations
Beachten Sie die folgenden Einschränkungen bei der Arbeit mit App Builder Connector:
- Der App Builder-Connector unterstützt Reach nicht.
- Der App Builder-Connector unterstützt Vollständige Audits, aber das vollständige Audit muss in der zugrunde liegenden Tabelle aktiviert sein, damit es funktioniert.
- Bei einem lokalen App Builder-Connector müssen beide Datenbanken relationale Datenbanken sein und in derselben Serverumgebung vorhanden sein.
- Bei einem lokalen App Builder-Connector müssen Sie, wenn Sie Spalten in einer öffentlichen Tabelle oder einem Business Object hinzufügen oder ändern, die entsprechenden Tabellen oder Business Objects auf jeder Seite manuell synchronisieren.
Hinweis
Es wird empfohlen, dedizierte Business Objects für die Verwendung mit dem App Builder-Connector zu erstellen, anstatt vorhandene wiederzuverwenden. Nachdem Sie ein Object importiert haben, ändern Sie das öffentliche Object nur wenn nötig. Falls Sie es ändern, nehmen Sie dieselbe Änderung auch am entsprechenden Object im lokalen App Builder-Connector vor.
Fehlerbehebung
Fehler 403 Forbidden
-
Symptom: Das Verbinden mit einer Remote-App Builder-Umgebung mit dem App Builder-Connector führt zu einem Fehler 403 Forbidden.
-
Mögliche Ursache: Das für den Connector konfigurierte Benutzerkonto hat in der App Builder-Quellumgebung nicht die Rolle App Builder Remote Connector erhalten.
-
Lösung: Weisen Sie dem Benutzer die Rolle App Builder Remote Connector zu. Konfigurationsschritte finden Sie unter Schritt 5: Eine Gruppe erstellen und ihr Zugriff gewähren im Remote Connector.
Vollständige Fehlerdetails
Response status code does not indicate success
at void Vinyl.Business.Application.Events.RemoteEventRunner.AssertSuccessStatusCode(HttpResponseMessage response, string uri, EventTableRef eventTableRef)
at async Task<EventTableRef> Vinyl.Business.Application.Events.RemoteEventRunner.Invoke(EventTableRef eventTableRef, VinylConnectorEndpoint connectorEndpoint)
at async Task<EventTableRef> Vinyl.Business.Application.Events.RemoteEventRunner.InvokeCountAsync(EventTableRef eventTableRef)
at async Task<EventTableRef> Vinyl.DataSource.VinylConnector.VinylConnectorDataSourceServerHandler.CountPublicDataSourcesAsync(EventContext eventContext)
at async Task Vinyl.DataSource.VinylConnector.VinylConnectorDataSourceServerHandler.PingAsync(EventContext eventContext, CancellationToken cancellationToken)
at async Task Vinyl.DataSource.Plugins.DataSourceManagement.PingDataSourceServer.InvokeAsync(ValidationRule validationRule, EventInputRow input)
Reason
Forbidden
Status
403
Uri
https://{{App BuilderRootURI}}/connector/v1/count
Remote DataSourceId
19b4051a-b959-4b0c-9bd4-98b7cf2be132
Remote Table Name
DataSource_Public
Remote Event Name
null
Source
Vinyl.Business
Weitere Informationen zur Fehlerbehebung finden Sie unter App Builder Connector: Generierter API-Schlüssel kann nach dem Verlassen des Bildschirms nicht abgerufen werden im App Builder-Leitfaden zur Fehlerbehebung.


